SIG Talk banner

1 - 3 of 3 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter #1 (Edited)
Well my new X-series compact grip (small) came today so I anxiously installed my compact components in it. The fcu fits just fine, a little tight like most new grips. Well I did a function check and as soon as I put a little pressure on the trigger I heard a faint click. Continued to pull the trigger to the wall (normal like before) and pulled it further to release the striker (also normal). So I tried it several times with the same results. You really can't feel the click in the trigger but can hear it. So I reinstalled my stock compact grip and no noise. Not sure if it's something with the apex trigger bar contacting the new grip or what's going on. The new x-grip is a small while the stock is oem medium. Anyone have any ideas what may be causing it? Like I said the trigger functions normally including the reset. Thanks in advance for any ideas or things to try. P.S. it doesn't make the noise when I have my fcu installed in my X-series full (small) grip.
 

Attachments

·
Registered
Joined
·
320 Posts
If you press the trigger a few times (20-30) and you remove the FCU from the new grip module, are there any wear marks in the area where the trigger bar is located (you’d likely see scuffing or wear marks on the plastic if it’s rubbing the trigger bar)???


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
109 Posts
Discussion Starter #3 (Edited)
I did look for rub marks but I only cycled the trigger maybe 4-5 times, but didn't see any marks. I'll cycle it a bunch when I get home from work and see if its rubbing. Guess if it isn't rubbing too much the dremel will fix it nicely. I was thinking the only time it makes the noise is after you cycle the slide to cock it, pressing the trigger after dry firing it doesn't do it. Thanks for the idea.
 
1 - 3 of 3 Posts
Top