SIG Talk banner

21 - 24 of 24 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #21 ·
Pete, how many rounds through the pistol? Just to get some perspective on the wear you're experiencing.
About 550 rounds total through pistol. Divided by about 5 mags. 3-12 round 1-10round and 1- 15 round. This started to happen after 330 shots, when I first installed the extended mag release and Icarus grip module. Fixed before I shot it again by changing out wedge. After firing the next 120 rounds (included in 550, but first time using the module and extended mag release) the problem came back
 

·
Registered
Joined
·
180 Posts
Can't help ya on your issue brother, but I had no luck with the Vuurwapen mag release. It started having mag "hang up" issues on release, and I noticed some serious wear when I removed it. I'm sticking with OEM factory mag release buttons from here on out. I've got 3 OEM Sig grip modules, and not one of them has issues. As much as I'd really like to try the Icarus billet module, I'm holding off.

For poops & giggles, try everything back to stock (poly Sig grip module & factory mag release.) If ya can... I certainly would.

Rock on
 

·
Registered
Joined
·
249 Posts
Looking from the outside it would seem that your Icarus grip module be the culprit. So prior to the Icarus and aftermarket mag releases, did your original configured pistol show any signs of having this issue?
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #24 ·
Looking from the outside it would seem that your Icarus grip module be the culprit. So prior to the Icarus and aftermarket mag releases, did your original configured pistol show any signs of having this issue?
Negative. I have a funny feeling it's the vuurwapen extended mag release. I have an AC one coming along with new mag release spring and wedge. Should be here by Monday. If that all fails I'm considering that as an option. However people over there have never heard of such issue. In the other 2 forums I posted no one has ever had this issue apparently. They say it was user error/installed wrong. I am confident when I say it was not me. I've changed mags releases half a dozen times already. Never had an issue.
 
21 - 24 of 24 Posts
Top