SIG Talk banner

1 - 12 of 12 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Last week I bought a new sig TACOPs .45 ACP 1911. I disassembled it (there was resistance when I took the slide off the frame) and cleaned it. When I reassembled it I could not get the slide to completly fit back onto the frame (left about ¾ of an inch of the frame showing). The plunger lever was not flush with the frame and I coudn't push it down with my thumb nail, or a hard plastic cleaning brush. I couldn't get the slide over the lever. I called Sig service and they gave me a FEDEX # to send it back to the service dept. No range time with the pistol and it's already going back to the service dept. - and now It's going to be 2-3 weeks before I can try again. This is the first problem I have had with a Sig product and I have owned a few. I wrote Sig a letter - mostly complementary - but let them know how disappointed I am. Hopefully they will make it right. We'll see.
 

·
Registered
Joined
·
111 Posts
Had the same problem with mine but the more i take it down the easier it gets. I just used my thumbnail to push down the plunger lever. Sig will take care of it for you.
 

·
Premium Member
Joined
·
18,373 Posts
Had the same problem with my 1911 Scorpion (born on date Oct 2012, purchased about a month ago). Appeared to be some flash across the top of the plunger lever. I stoned it and it worked fine. Since, however, the gun has been shipped to Exeter to be gone through. I wanted to make sure there was nothing more severe wrong with the lever.

sent from my rotary dial phone using tapatalk2
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
I returned mine too and I should get it back later this week. Excited to shoot it!
 

·
Registered
Joined
·
1,434 Posts
Sorry to hear about your troubles. I have read about the same issue with a number of their 1911 plungers. I have sent in a gun to Sig for a warranty job and they said 2-3 weeks more so I wouldn't call then frantic. I would bet you will wait no more than two weeks total, including shipping (mine took 10 days round trip over a holiday weekend). Don't fret, I am sure they will get the plunger issue right and you will forget you ever had an issue after some range time!
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
I recieved my repaired Tacops last Friday and it seems to be fixed. I haven't been to the range yet so I can't say for sure. On the plus side - the gunsmith did me right. He added a skeleton trigger to match the skeleton hammer. It looks great and I think he did a trigger job as well, seems like an even lighter and more crisp pull.
I bought a CT Lasergrip to install and am buying the shortened ambi thumb safety as well.
I hope to get out to fire it soon, I can't go out this week due to sinus surgery, but as soon as I am cleared to go I will pass on an update!
 

·
Registered
Joined
·
1,434 Posts
Great news! Hope you get well soon and we can get a range report. Glad to hear Sig did you right.
 

·
Registered
Joined
·
29 Posts
I recieved my repaired Tacops last Friday and it seems to be fixed. I haven't been to the range yet so I can't say for sure. On the plus side - the gunsmith did me right. He added a skeleton trigger to match the skeleton hammer. It looks great and I think he did a trigger job as well, seems like an even lighter and more crisp pull.
I bought a CT Lasergrip to install and am buying the shortened ambi thumb safety as well.
I hope to get out to fire it soon, I can't go out this week due to sinus surgery, but as soon as I am cleared to go I will pass on an update!
Looks like we had almost the identical problem. Mine was with a brand new Scorpion though. Gunsmith hooked me up as well polished my feed ramp which was nice for my troubles. Glad you were taken care in the same way I was, shows consistent customer service
 

·
Registered
Joined
·
16 Posts
Discussion Starter #10
Finally a range report with the Tacops. I had my gunsmith mount a burris fastfire 3 on the TACOPS and it worked great. The Burris was not a plug and play, that's why I got help from the gunsmith. He had to take some material off the mount because the Tacops slide is squared a little more than your standarad govt. 1911. Anyway - I love the tacops. it is the most accurate pistol I have ever fired and I have fired a few.
The fastfire was incredible, I am 52 and farsighted. The fastefire allowed me to see the front sight without wearing reading glasses. If your wear reading glasses the target will be a blur, not good for accuracy. The tacops is my home defense pistol so I also added a CT laser grip, works great in low light and the fastfire is not a problem either on or off because at 25' they line up perfectly. Also the fastfire is less than an ounce and doesn't affect the action at all. I just bought a advantage arms 1911T conversion kit and will buy another fastfire 3 to mount on it permanantly for target practice.
 

·
Registered
Joined
·
2,505 Posts
I recieved my repaired Tacops last Friday and it seems to be fixed. I haven't been to the range yet so I can't say for sure. On the plus side - the gunsmith did me right. He added a skeleton trigger to match the skeleton hammer. It looks great and I think he did a trigger job as well, seems like an even lighter and more crisp pull.
I bought a CT Lasergrip to install and am buying the shortened ambi thumb safety as well.
I hope to get out to fire it soon, I can't go out this week due to sinus surgery, but as soon as I am cleared to go I will pass on an update!
Uh oh, I think my Sig 1911 Fastback Carry is starting to break...yup exact same problem. :lol:

Just kidding, mine is working, it has been getting easier to reassemble as the gun breaks in more, its like the firing pin safety is learning how to behave itself. I reassembled my 1911 very easily after shooting and cleaning it over the weekend. The only hiccup was after I reassembled it I saw the main recoil spring still lying on the counter. :lol:
 

·
Registered
Joined
·
84 Posts
Those main recoil springs are over rated, I shoot my sig nightmare without it all the time. ;) yeah right.



Sent from my SCH-I535 using Tapatalk 2
 
1 - 12 of 12 Posts
Top