SIG Talk banner

P320C FTF...What is going on?

844 Views 4 Replies 3 Participants Last post by  Mills
Hey everyone,
So a buddy and I went to the range on Friday and today, and a extremely odd issue came about on my P320C. When I pull the trigger sometimes, there is an audible click, but the striker doesn't fire. Then if I pull the trigger again, it will fire. Sometimes it will do the click more than once. If I torque the trigger, it will sometimes go off too. It almost feels as if the FCU isn't directly contacting the striker assembly and 'slips off' per se. I also had 1 light primer strike. Only modifications I've done are the PELT trigger. I've fired over 300 rounds after installing the trigger - so I know that's not the issue. Please, for the love of shooting, someone help me with this.
1 - 5 of 5 Posts

· Registered
Joined
·
34 Posts
Discussion Starter · #3 ·
Took apart the FCU completely, found nothing wrong. Took the firing pin out... and the striker safety spring is not there.... I think I found the problem.... But 13$ for a little spring from Numrich?????? Thats a ton of dinero for a itty bitty spring. I'll probably call sig tomorrow....
 

· Registered
Joined
·
34 Posts
Discussion Starter · #4 ·
Okay, its not the striker safety spring. Everything is in order. I reinstalled the original trigger spring and sometimes it will fire on the first pull, other times I must torque the trigger left or right to make it fire. I'm gaining a lot of distrust in this gun. It's really starting to **** me off. Any suggestions?
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top