SIG Talk banner

Loose rail on my brand new 516 Trooper

785 5
I purchased a brand new Sig Sauer 516 Trooper in March. I finally had a opportunity to fire and zero this rifle for the first time. I expected some minor faults being the first time shooting my new rifle. What I didn't expect was to discover that the rear sight was loose. Upon further looking I discovered that the entire rail on the upper was loose. Has anyone else had this problem? I will be returning it to the retailer this week, hoping to get it fixed. I really like Sig Sauer products and wanted this rifle for a very long time.
1 - 6 of 6 Posts

·
Registered
Joined
·
1,490 Posts
Im not familiar with a Trooper model, can you post some pics, as this may be something unique to that model? I have a Patrol, and the upper rail before the forend is integral to the upper receiver and could not be loose on the receiver. You could have a rear sight that is not tightened down properly or could have excessive play between the upper and lower receivers, which can be adjusted.
 

·
Premium Member
Joined
·
3,766 Posts
I wish I had an answer to your loose rail but I'm unfamiliar with the 516 Trooper. I did want to jump in and extend a welcome to SigTalk to you. I hope another has a solution.
Greetings from the flat lands of Kansas.
 

·
Registered
Joined
·
7,967 Posts
Mr Schlick is either very confused or simply another internet Troll. There are state troopers with SIG516s, but there ain't no SIG 516 Trooper rifle. And if there were, the pic rail is part of the upper...

Cheers
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top